スポンサーリンク

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。

2018年8月15日

「日本の学年別のプログラミングカリキュラムを探しています。」
「プログラミングを英単語を使わないで学びたいです。」
この記事は、そんな方へ向けて書いています。
教育用に設計されたプログラミング言語ドリトルの小学校の授業向け「ドリトルではじめるプログラミング」を紹介します。
ドリトルはひらがなと漢字だけで動くプログラミングですので、英単語がまったく分からなくても大丈夫です。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。

ドリトルではじめるプログラミング小学生向け(教育用言語ドリトル)

ドリトルではじめるプログラミング(小学生向け)の内容

ドリトルは教育用に設計されたプログラミング言語です。
中学校・高校の教科書や副教材などに採用されています。
小学校(総合・算数・理科・音楽など)、中学校(技術科の計測制御・双方向コンテンツ)、高等学校(情報の科学・社会と情報、情報I・情報II)、大学(プログラミング入門、IoT)などで利用されています。
使い方には、オンラインでインストールせずに使う方法とインストールして使う方法の2通りが可能です。
情報ページには、「使い方」やダウンロード版、掲示板や書籍情報などが載っていますよ。

ドリトルではじめるプログラミング(小学生向け)の感想

日本語で会話するように直感的にプログラミングが学べます。
単元ではすでにプログラミングが出来上がっているので、一度かめを動かしたらコードを変更したり消したりしてオリジナルのコードで図形を作ってみるのが良さそうです。
HourofCodeにも図形を描いたりするのがあるので、それに近い印象でした。
ただ通常の英語のプログラミングに慣れている方だと逆に戸惑ってしまうかもしれません。
書籍などには応用が載っているのかもしれないですが、もう少しいろいろな使い方が提示されているともっと良くなるかも、です。

さぁ、「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」でプログラミングをはじめよう。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。1

ドリトルの情報ページから
「オンラインで使ってみよう」から「小学校向け特設ページ(ドリトルではじめるプログラミング)」をクリックします。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。2

ドリトルではじめるプログラミングのなかから
まずは右の「使い方」をクリックします。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。3

下へスクロールしていくと、基本操作やコマンド一覧で一通りの使い方が学べます。
学び終わったら、ひとつ前の画面に戻ります。
そうしたら左の「単元から選ぶ」を選択します。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。4

左の「5年生」から「多角形の作図」を選択します。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。5

すでに出来ているコードを消して、基本操作で四角形を描いてみました。
9行の長いコードになってしまいました。

かめた=タートル!作る。
かめた!100 歩く。
かめた!90 左回り。
かめた!100 歩く。
かめた!90 左回り。
かめた!100 歩く。
かめた!90 左回り。
かめた!100 歩く。
かめた!90 左回り。

でも、よく見ると同じ行がありますね。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。6

これで同じ四角形のプログラミングが5行におさまりました。

かめた=タートル!作る。
かめた!100 歩く 90 左回り。
かめた!100 歩く 90 左回り。
かめた!100 歩く 90 左回り。
かめた!100 歩く 90 左回り。

でも、もう少し短くできそうです。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。7

これで重複していた行や言葉はなくなりました。

かめた=タートル!作る。
「かめた!100 歩く 90 左回り」!4 繰り返す。

このコードが元々あったものでした。
繰り返し(ループ)のコードが学べたはずです。
ではひとつ前の画面に戻って、「多角形と外接円」を選択します。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。8

出来ているプログラミングを実行してみると、円とそれに接する八角形が出来上がりました。
では、ひとつ前の画面に戻ります。
「グラフの特徴と使い方」を選択します。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。9

上は左上のプルダウンから「スポーツ」を選択した結果です。
右下のグラフ選択から「円グラフ」を選択してみます。

「ドリトルではじめるプログラミング小学生向け5年生(教育用言語ドリトル)」をやってみました。10

そうすると、左のデータから右に円グラフができました。
円グラフを作成したプログラミングが左下に表示されているのが分かりますね。

ほかにもドリトルでは「図形を中心で回転させる」や「6年生」の単元なども用意されていますよ!(^^)!

最初は誰だって初心者です。
やりながら順番に覚えていきましょう。
さぁ、プログラミングをはじめましょう。